Name

Contact

Position

Address:
Address City State ZIP Code Country

Phone: Telephone

Fax: Fax

Mobile: Mobile

Contact Form

Send an Email. All fields with an asterisk (*) are required.

Newsflash Items

The Joomla! team has millions of good reasons to be smiling about the Joomla! 1.5. In its current incarnation, it's had millions of downloads, taking it to an unprecedented level of popularity. The new code base is almost an entire re-factor of the old code base. The user experience is still extremely slick but for developers the API is a dream. A proper framework for real PHP architects seeking the best of the best.

If you're a former Mambo User or a 1.0 series Joomla! User, 1.5 is the future of CMSs for a number of reasons. It's more powerful, more flexible, more secure, and intuitive. Our developers and interface designers have worked countless hours to make this the most exciting release in the content management system sphere.

Go on ... get your FREE copy of Joomla! today and spread the word about this benchmark project.

System Requirements

The following are required for Omnicron to operate fully:

  • Joomla 1.5.x (latest version)
  • Gantry v3.0.10 or higher
  • PHP 5.2 or higher
  • RokNavMenu Module

Service Updates

OFFLINE: 31.08.10 @ 12:31 EST. Sharing hosting servers are currently disabled due to a backup error. http://bit.ly/bWZUiKq
RESTORED: 29.08.10 @ 18:53 EST. Email has been restored. All received messages are now synced. http://bit.ly/cWXUiFt
OFFLINE: 28.08.10 @ 23:14 EST. Our email system is down. Backup servers are trapping all sent emails. http://bit.ly/wQDSpKl

Our Partners

Sponsors